[MediaWiki]
url=https://www.mediawiki.org/
safe=1.31.1
old_safe=1.30.1,1.29.3,1.27.5
latest=1.31.1
vuln=CVE-2018-0505
file=DefaultSettings.php
variable=$wgVersion
subdir=1
upgradeinstructions=https://www.mediawiki.org/wiki/Manual:Upgrading

[TWiki]
url=http://twiki.org/
safe=5.0.1
vuln=CVE-2010-3841
file=TWiki.pm
variable=$RELEASE
subdir=1

[PmWiki]
url=http://www.pmwiki.org/
safe=2.2.96
vuln=http://www.pmwiki.org/wiki/PmWiki/ChangeLog
file=version.php
variable=$Version
extra_match=pmwiki
subdir=1

[TikiWiki]
url=http://tikiwiki.org/
safe=5.3
old_safe=3.8
vuln=CVE-2010-4239
file=twversion.class.php
variable=$this->version
subdir=2

[TikiWiki-old]
url=http://tikiwiki.org/
safe=5.3
old_safe=3.8
vuln=CVE-2010-4239
file=README
variable=version
extra_match=Tiki! The wiki
subdir=0

[phpwiki]
url=http://phpwiki.sourceforge.net/
safe=1.3.14
vuln=CVE-2007-3193
file=prepend.php
variable=PHPWIKI_VERSION
subdir=1

[phpwiki-legacy]
url=http://phpwiki.sourceforge.net/
safe=1.3.14
vuln=CVE-2007-3193
file=config.php
variable=PHPWIKI_VERSION
subdir=1

[etherpad-lite]
url=http://etherpad.org/
# not really, 1.1.3 is safe, but 1.1.3/1.1.4 contain wrong version string
safe=1.1.2
vuln=http://etherpad.org/
file=package.json
variable=version
extra_match=https://github.com/Pita/etherpad-lite
subdir=0