Browse code

properly detect subdir of phpMyAdmin 4.8 and above

Hanno Böck authored on24/06/2018 20:37:51
Showing1 changed files
... ...
@@ -1,4 +1,4 @@
1
-[phpMyAdmin-old]
1
+[phpMyAdmin-veryold]
2 2
 url=http://www.phpmyadmin.net/
3 3
 safe=4.7.8
4 4
 vuln=CVE-2018-7260
... ...
@@ -13,6 +13,16 @@ vuln=CVE-2018-7260
13 13
 file=Config.php
14 14
 variable=PMA_VERSION
15 15
 subdir=1
16
+extra_match=namespace PMA\libraries;
17
+
18
+[phpMyAdmin-old]
19
+url=http://www.phpmyadmin.net/
20
+safe=4.7.8
21
+vuln=CVE-2018-7260
22
+file=Config.php
23
+variable=PMA_VERSION
24
+subdir=2
25
+extra_match=namespace PhpMyAdmin;
16 26
 
17 27
 [SquirrelMail]
18 28
 url=http://www.squirrelmail.org/