git.schokokeks.org
Repositories
Help
Report an Issue
keks-overlay.git
Code
Commits
Branches
Tags
Suche
Strukturansicht:
8c4e5b8
Branches
Tags
master
keks-overlay.git
net-im
pyaim-t
pyaim-t-0.7c.ebuild
A keks * initial commit
Lars Strojny
commited
8c4e5b8
at 2006-12-17 11:28:02
pyaim-t-0.7c.ebuild
Blame
History
Raw
# Copyright 1999-2006 BreakMyGentoo.net # Distributed under the terms of the GNU General Public License v2 # $Header: $ inherit eutils python DESCRIPTION="New Python based jabber transport for AIM" HOMEPAGE="http://pyaim-t.blathersource.org/" SRC_URI="http://www.blathersource.org/download.php/${PN}/${P}.tar.gz" LICENSE="GPL-2" SLOT="0" KEYWORDS="~x86" DEPEND=">=net-im/jabber-base-0.0 >=dev-lang/python-2.3" RDEPEND=">=dev-python/twisted-1.3.0 >=dev-python/twisted-words-0.1.0 >=dev-python/twisted-xish-0.1.0 >=dev-python/twisted-web-0.5.0 >=dev-python/nevow-0.4.1 >=dev-python/imaging-1.1" IUSE="" src_install() { python_version insinto /usr/lib/python${PYVER}/site-packages/${PN}/ doins -r tools src data newins PyAIMt.py ${PN}.py insinto /etc/jabber newins config_example.xml ${PN}.xml fperms 600 /etc/jabber/${PN}.xml fowners jabber:jabber /etc/jabber/${PN}.xml dosed \ "s:<spooldir>[^\<]*</spooldir>:<spooldir>/var/spool/jabber/</spooldir>:" \ /etc/jabber/${PN}.xml dosed \ "s:<pid>[^\<]*</pid>:<pid>/var/run/jabber/${PN}.pid</pid>:" \ /etc/jabber/${PN}.xml exeinto /etc/init.d newexe ${FILESDIR}/${P}.initd ${PN} dosed "s/PATH/python${PYVER}/" /etc/init.d/${PN} } pkg_postinst() { einfo "A sample configuration file has been installed in /etc/jabber/${PN}.xml." einfo "Please edit it, and the configuration of you Jabber server to match." einfo "You also need to create a directory aim.yourjabberhostname.tld in" einfo "/var/spool/jabber and chown it to jabber:jabber." }