# Copyright 1999-2006 BreakMyGentoo.net
# Distributed under the terms of the GNU General Public License v2
# $Header: $
inherit eutils python subversion
ESVN_REPO_URI="svn://svn.blathersource.org/pyicq-t/trunk"
#ESVN_PROJECT="pyicq-t"
DESCRIPTION="New Python based jabber transport for ICQ"
HOMEPAGE="http://pyicq-t.blathersource.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
DEPEND=">=net-im/jabber-base-0.0
>=dev-lang/python-2.3"
RDEPEND=">=dev-python/twisted-1.3.0
>=dev-python/twisted-words-0.1.0
>=dev-python/twisted-xish-0.1.0
>=dev-python/twisted-web-0.5.0
>=dev-python/nevow-0.4.1
>=dev-python/imaging-1.1"
IUSE=""
S=${WORKDIR}/${PN}/
src_install() {
python_version
insinto /usr/lib/python${PYVER}/site-packages/${PN}/
doins -r tools data src
newins PyICQt.py ${PN}.py
insinto /etc/jabber
newins config_example.xml ${PN}.xml
fperms 600 /etc/jabber/${PN}.xml
fowners jabber:jabber /etc/jabber/${PN}.xml
dosed \
"s:[^\<]*:/var/spool/jabber/:" \
/etc/jabber/${PN}.xml
dosed \
"s:[^\<]*:/var/run/jabber/${PN}.pid:" \
/etc/jabber/${PN}.xml
exeinto /etc/init.d
newexe ${FILESDIR}/${P}.initd ${PN}
dosed "s/PATH/python${PYVER}/" /etc/init.d/${PN}
}
pkg_postinst() {
einfo "A sample configuration file has been installed in /etc/jabber/${PN}.xml."
einfo "Please edit it, and the configuration of you Jabber server to match."
einfo "You also need to create a directory icq.yourjabberhostname.tld in"
einfo "/var/spool/jabber and chown it to jabber:jabber."
}