Browse code

php 5.6 zum default, php 5.3 raus

Hanno Böck authored on05/11/2014 15:42:06
Showing4 changed files
... ...
@@ -103,7 +103,7 @@ $form .= "<br /><input type=\"checkbox\" name=\"options[]\" id=\"aliaswww\" valu
103 103
 /*
104 104
  * Boolean option, to be used when only one PHP version is available
105 105
  */
106
-$have_php = ($vhost['php'] == 'php55' ? ' checked="checked" ' : '');
106
+$have_php = ($vhost['php'] == 'php56' ? ' checked="checked" ' : '');
107 107
 
108 108
 /*
109 109
 $phpoptions = "<h5>PHP</h5>
... ...
@@ -117,7 +117,7 @@ $phpoptions = "<h5>PHP</h5>
117 117
  */
118 118
 //if ($vhost['php'] == 'php54')
119 119
 //{
120
-  $options = array("none" => 'ausgeschaltet', "php53" => 'PHP 5.3 (veraltet)' , "php54" => "PHP 5.4 (veraltet)", "php55" => "PHP 5.5", "php56" => "PHP 5.6 (experimentell)");
120
+  $options = array("none" => 'ausgeschaltet', "php54" => "PHP 5.4 (veraltet)", "php55" => "PHP 5.5", "php56" => "PHP 5.6");
121 121
   $phpoptions = "
122 122
   <h5>PHP</h5>
123 123
   <div style=\"margin-left: 2em;\">
... ...
@@ -85,7 +85,7 @@ function empty_vhost()
85 85
   
86 86
   $vhost['homedir'] = $_SESSION['userinfo']['homedir'];
87 87
   $vhost['docroot'] = NULL;
88
-  $vhost['php'] = 'php55';
88
+  $vhost['php'] = 'php56';
89 89
   $vhost['cgi'] = 1;
90 90
   $vhost['ssl'] = NULL;
91 91
   $vhost['hsts'] = -1;
... ...
@@ -72,15 +72,6 @@ if ($_GET['action'] == 'edit')
72 72
   if ($_POST['vhost_type'] == 'regular' && isset($_POST['php']))
73 73
   {
74 74
     switch ($_POST['php']) {
75
-      case 'mod_php':
76
-        $php = 'mod_php';
77
-        break;
78
-      case 'fastcgi':
79
-        $php = 'fastcgi';
80
-        break;
81
-      case 'php53':
82
-        $php = 'php53';
83
-        break;
84 75
       case 'php54':
85 76
         $php = 'php54';
86 77
         break;
... ...
@@ -132,9 +132,6 @@ if (count($vhosts) > 0)
132 132
         case NULL:
133 133
           $php = icon_disabled('PHP ausgeschaltet');
134 134
           break;
135
-        case 'php53':
136
-          $php = icon_enabled_warning('PHP in veralteter Version aktiviert');
137
-          break;
138 135
         case 'php54':
139 136
           $php = icon_enabled_warning('PHP in veralteter Version aktiviert');
140 137
           break;